FTP-Replikator - Allgemein

FTP-Replikator - Online-Hilfe
Stand: 23. Oktober 2003

Vorgehen beim Lesen dieser Online-Dokumentation

Wenn Sie möglichst schnell mit dem FTP-Replikator arbeiten möchten, empfehlen wir Ihnen die Verwendung des Kapitels Schnelleinstieg im Anhang. Ansonsten arbeiten Sie einfach die einzelnen Kapitel dieser Online-Dokumentation von Anfang bis Ende durch.

Allgemeines oder "Was ist eigentlich Replikation?"

Unter Replikation und Synchronisation versteht man den Vergleich mehrerer Dateisysteme mit dem Ziel, durch Erstellen von Ordnern und Kopieren von Dateien zwei identische Systeme zu erhalten. Bei der Replikation wird ein Dateisystem A in nur einer Richtung mit einem Dateisystem B verglichen: diejenigen Dateien und Ordner werden kopiert, die zwar in A vorhanden sind, aber nicht in B, oder dort älteren Datums sind. Dateien und Ordner in B, die nicht in A enthalten sind, werden gelöscht.

Bei der Synchronisation wird zunächst A mit B verglichen und repliziert, und danach B mit A. Synchronisation ist also nichts anderes als eine bidirektionale Replikation.

Leistungsmerkmale

Der FTP-Replikator ist eine Anwendung zur Replikation und Synchronisation lokaler Dateisysteme, Netzwerkserver im LAN sowie FTP-Server über das Intra- bzw. Internet. Folgende Kern-Leistungsmerkmale zeichnen das Programm aus:

  • automatischer Auf- und Abbau einer DFÜ-Verbindung (beispielsweise über ISDN, Kabelmodem, DSL etc.)
  • automatische Verbindung zum und Benutzerauthentifizierung am FTP-Server
  • Offline-Vergleich mit dem Datenbestand des FTP-Servers (spart Telefonkosten)
  • hohe, konfigurierbare Fehlertoleranz bei FTP-Übertragungen
  • Unterstützung von CERN-Proxies (optional)
  • beliebig viele Tätigkeitsprofile zur Replikation und Synchronisation
  • Permanentüberwachung der definierten Ordnerbäume
  • Sicherstellen einer Vorbedingung vor der Ausführung eines Vergleichs
  • Automatische Ausführung einer externen Anwendung nach erfolgter Replikation oder Synchronisation
Im Nur-FTP-Modus der unregistrierten Version dieses FTP-Replikators können ausschließlich Replikationen zwischen lokalen und entfernten FTP-Datenbeständen vorgenommen werden. Replikationen und Synchronisationen zwischen lokalen Datenbeständen sind dagegen nicht möglich.

topicAllgemein.html


FTP-Replikator - Nutzen

Nutzen

Die Bedeutung der Replikation und Synchronisation nimmt mit der Notwendigkeit verteilter Dateisysteme im WAN oder Web, sowie mit den ständig wachsenden Datenmengen im Unternehmen in gleichem Maße zu.

Informieren Sie sich hier in einem theoretischen Artikel über den sinnvollen Einsatz dieser Verfahren.

topicNutzen.html


FTP-Replikator - Neuigkeiten

Ihr Browser unterstützt leider keine Frames. Sorry.


FTP-Replikator - Startoptionen

Startoptionen

Die Hauptanwendung heißt FTP-Replikator.exe und befindet sich in dem von Ihnen während der Programminstallation ausgewählten Ordner. Sie wird über den üblichen Weg zum Ausführen von Windows-Anwendungen gestartet (konsultieren Sie im Zweifelsfall bitte Ihr Windows-Handbuch).

Zwei zusätzliche Aufrufparameter ermöglichen den Aufruf von Programmfunktionen schon während des Starts:

profile=<profile> | lädt bei Programmstart das angegebene Profil <profile>
+autostart | startet den Vergleichsvorgang mit anschließendem Replikations- oder Synchronisationsvorgang bereits beim Programmstart, und nicht erst nach Klick auf die Schaltfläche Vergleichen (lesen Sie hierzu bitte auch das Kapitel Vorbereitungen des Vergleichs)

topicStart.html


FTP-Replikator - Copyright

Copyright

Dieses Programm ist durch deutsche Urheberrechtsgesetze geschützt. Unbefugte Vervielfältigung oder unbefugter Betrieb dieses Programms oder eines Teils davon ist strafbar. Dies wird sowohl straf- als auch zivilrechtlich verfolgt und kann schwere Strafen und Schadenersatzforderungen zur Folge haben!

Geist Informatik
Dipl.-Inform. Thomas Ziemer
Glockenblumenweg 50 B
D-12357 Berlin

support@geist-informatik.de
vertrieb@geist-informatik.de

Fon +49 (30) 8 43 09-246
Fax +49 (30) 8 43 09-247

Copyright © 2001-03Geist Informatik. Alle Rechte vorbehalten.

Copyright.html


FTP-Replikator - Professional-Oberfläche

Die Professional-Oberfläche

Abbildung "Professional-Oberfläche"

Oben ist die Abbildung der Professional-Oberfläche des FTP-Replikators zu dargestellt. Hier sehen Sie in einer übersichtlichen Baumstruktur auf einen Blick, welche Verzeichnisse in den Profilen repliziert oder synchronisiert werden.

Die Professional-Version des FTP-Replikators steht als optionales Zusatzpaket zur Verfügung, welches käuflich erworben werden kann.

Zeitgesteuerte Profilausführung

In der Professional-Oberfläche des FTP-Replikators haben Sie immer den Überblick über alle Replikations- und Synchronisations-Profile, die darin in einer Baumstruktur aufgelistet werden. Handelt es sich um ein zeitgesteuertes Profil, welches in regelmäßigen Zeitabständen automatisch ausgeführt wird, so wird dies durch einen roten oder grünen Farbpunkt im Symbol der entsprechenden Profilzeile angezeigt, und hinter dem angezeigten Profilnamen steht der genaue Zeitpunkt der nächsten Ausführung. Ein grüner Farbpunkt bedeutet, dass die zeitgesteuerte Profilausführung tatsächlich stattfindet. Ein roter Punkt zeigt einen deaktivierten Timer an. Das heisst, dass die zeitgesteuerte Ausführung für dieses Profil ausser Kraft gesetzt ist. Klicken Sie mit der rechten Maustaste auf ein Profil und wählen Sie im erscheinenden Kontextmenü den Punkt Timer aktiviert. Ein Häkchen zeigt hier an, wenn die zeitgesteuerte Ausführung aktiviert ist. Im Menü Profil->Timer aktiviert steht diese Funktion ebenfalls zur Verfügung.

Sie können die zeitgesteuerte Ausführung für alle Profile mittels der Schaltfläche mit dem Uhrensymbol an- und abschalten. Diese Funktion hat eine höhere Priorität als die Timeraktivierung für ein einzelnes Profil.

Profile neu erstellen, bearbeiten und löschen

Klicken Sie auf eine Zeile in der Baumstruktur, um in dem erscheinenden Kontextmenü das gewählte Profil zu bearbeiten, zu löschen oder ein neues Profil anzulegen. Die gleiche Funktion steht Ihnen über die Menüs Datei->Neu..., Datei->Bearbeiten... und Datei->Löschen zur Verfügung, bzw. über die Schaltfläche mit dem Papiersymbol, mit dem sich öffnenden Ordner und dem Papierkorb. Beim Neuerstellen oder bearbeiten eines Profils öffnet sich hierzu die klassische Darstellung des FTP-Replikators.

Profil vergleichen

Um den Vergleichsvorgang für ein Profil manuell anzustossen, klicken Sie mit der rechten Maustaste auf die gewünschte Profilzeile, und wählen Sie im Kontextmenü den Eintrag Profil vergleichen. Die selbe Funktion steht Ihnen über das Menü Datei->Vergleichen zur Verfügung, bzw. über die Schaltfläche mit den Pfeilen.

topicProfessional.html


FTP-Replikator - Professional-Oberfläche und Shareware

Die Professional-Oberfläche im Shareware-Modus

Die Professional-Oberfläche ist im Shareware-Modus des FTP-Replikators sowie in der Standardversion leider nicht erreichbar. Setzen Sie sich zum Erwerb einer Professionalversion bitte mit unserem Vertrieb in Verbindung.

topicProfessionalShareware.html


FTP-Replikator - Vorbereitungen des Vergleichens

FTP-Replikator und Profile - Vorbereitungen des Vergleichs

Abbildung "FTP-Replikator Startmaske"

Profile

Darum dreht sich alles. In sogenannten Profilen werden sämtliche Vergleichs- und Replikationsregeln definiert. Sie stellen quasi die Ablaufbeschreibung für alle auszuführenden Replikationen oder Synchronisationen dar. Hierin werden auch alle Angaben über die zu prüfenden Ordner gemacht, und ebenso die Art und Weise definiert, wie diese Ordner später geprüft (verglichen) werden sollen.

In der Kopfzeile der Maske wählen Sie ein bereits erstelltes Tätigkeitsprofil, erstellen ein neues oder speichern das augenblickliche Profil. Die Profile werden intern im Programm-Unterordner Profile abgelegt. Diese beiden Funktionen sind auch über die Menüs Datei->Neu und Datei->Speichern erreichbar.

Über Profile, von denen beliebig viele erstellt werden können, lässt sich die gesamte Replikation oder Synchronisation der Anwendung steuern. Damit sind Platte-zu-Platte Konfigurationen ebenso möglich wie Platte-zu-Rechner/Server, Platte-zu-mehreren-Rechnern/Servern, Server-zu-Server usw.

Zeitgesteuerte Profilausführung

Über das Uhrensymbol lässt sich eine zeitgesteuerte Profilausführung starten. Alle ausgewählten Profile werden danach permanent überwacht und synchronisiert bzw. repliziert. Der Abschnitt Zeitgesteuerte Profilausführung informiert detailliert über diese Funktion.

Modus (lokal oder FTP)

Ferner wird hier über die Schaltfläche FTP oder im Menü Modus->FTP zwischen FTP- und Dateisystemprofilen ausgewählt. Im Modus FTP wird ein lokales Dateisystem bzw. ein lokales Netzwerk mit einem FTP-Server verglichen. Im anderen Modus werden nur lokale bzw. Netzwerkdateisysteme miteinander verglichen.

Ein Profil kann alle Ordner in der Liste Linker Ordner (oder auszuschließender) in eine bestimmte Richtung (entweder von links nach rechts oder von rechts nach links) mit denen der Liste Rechter Ordner (oder entfernter) replizieren (Schaltflächen Pfeil nach rechts bzw. Pfeil nach links) oder aber in beide Richtungen synchronisieren (Schaltfläche Pfeil nach links und rechts). Die Menüs unter Modus->... beinhalten ebenfalls diese Funktionen.

Wird im FTP-Modus von links nach rechts verglichen, muss hierzu in den meisten Fällen keine Online-Verbindung zum FTP-Server aufgebaut werden, da der FTP-Replikator den Datenbestand des FTP-Servers bereits bei der letzten Replikation in den internen Vergleichstabellen gespeichert hat. Dies spart unter Umständen viele Telefonkosten.

Zu vergleichende Ordner hinzufügen

Mit der Schaltfläche Ordnersymbol mit grünen Haken bzw. im Menü Replikation->Ordner hinzufügen werden die in den (beiden) Ordnerbäumen ausgewählten Ordner in die entsprechenden Listen kopiert.

Im FTP-Modus müssen die entfernten Ordnerpfade manuell in die Liste eingetragen werden, da nur der lokale Ordnerbaum zur Auswahl angezeigt wird. Eine weitere Abbildung zeigt hierzu eine typische Startmaske. Zur Verbindung mit dem FTP-Server muss der Name des FTP-Servers und dessen Port, sowie bei Bedarf ein Benutzername und Kennwort angegeben werden. Ist die Checkbox Kennwort merken aktiviert, so muss das Kennwort beim nächsten Mal nicht mehr wieder eingegeben werden. Es wird dann leicht verschlüsselt im Profil gespeichert und ist immer verfügbar. Achtung: hierin liegt ein potentieller Sicherheitsschwachpunkt! Diese Funktion ist mit äußerster Vorsicht zu verwenden. Wir empfehlen, nur dann Gebrauch von ihr zu machen, wenn nur Sie allein an dem PC arbeiten, auf dem der FTP-Replikator installiert ist.

Mit den Schaltflächen Verbinden und Trennen oder über die gleichnamigen Einträge im Menü FTP kann zu Testzwecken eine Verbindung zum FTP-Server auf- und wieder abgebaut werden. Diese beiden Schaltflächen sind jedoch nur dann verwendbar, wenn Sie nicht über eine permanente Verbindung ins Internet verfügen. Lesen Sie diesbezüglich bitte auch hier.

Über die Schaltfläche Erweitert... sind weitere Einstellungen möglich, beispielsweise die Auswahl zwischen LAN- und Modem-Verbindung, Proxyserver und FTP-Verbindungs- bzw. Übertragungsparameter. Diese Funktion ist auch über das Menü FTP->Erweitert... erreichbar (siehe hierzu auch die Abbildung dieser Eingabemaske).

Erweiterte Vergleichskriterien

In den einzelnen Zeilen der Ordnerliste kann mittels der Checkboxen in der Spalte Lösch angegeben werden, ob die Quelldatei nach ihrer erfolgreichen Übertragung gelöscht werden soll.

Mittels Unter kann angegeben werden, ob vorhandene Unterordner des angegebenen Ordners bei der Replikation oder Synchronisation ebenfalls berücksichtig werden sollen.

Mittels der Radiergummi-Schaltfläche werden einzelne Zeilen aus den Listen entfernt, während sie über die Schaltfläche mit der Tarnkappe (von manchen Benutzern auch liebevoll die Fledermausfunktion genannt ;-) zwar weiterhin in den Listen enthalten sind, aber während eines Vergleichs keine Berücksichtigung mehr finden. Genaueres zu dieser komplexen Funktion entnehmen Sie bitte dem Kapitel Bestimmte Ordner von der Replikation ausschließen.

Der zu ignorierende Unterordner muss zwingend in der linken Hälfte der Ordnerlisten angegeben werden, um wirksam zu sein!

Diese beiden Funktionen sind auch über die Menüs Replikation->Ordner entfernen und Replikation->Ordner ignorieren zugänglich.

Erweiterte Replikationskriterien

Über die Checkbox Sicherung überschriebener Dateien kann festgelegt werden, ob vor dem Überschreiben bereits vorhandener Dateien der alte Dateiinhalt gesichert werden soll. Die ehemalige Datei erhält dann die Dateierweiterung .bak im Namen. Über die Checkbox mit Versionsverwaltung erstellen werden zusätzlich mehrere Generationen der überschriebenen Dateien gesichert. Dazu wird das jeweilige Sicherungsdatum dem Dateinamen hinten angehangen. Im Datenfeld Bestimmte Dateien ausschließen können Dateien spezifiziert werden, die nicht repliziert oder synchronisiert werden, beispielsweise:

  • *.txt
    Alle Dateien mit der angegebenen Dateierweiterung im Namen, hier txt
  • Kopie von...
    Alle Dateien, deren Name mit dem angegebenen Text beginnt, hier mit Kopie von
  • autoexec.bat
    Alle Dateien mit dem angegebenen Namen, hier autoexec.bat

Mehrere Angaben im Datenfeld können mit Kommata voneinander getrennt werden.

Über die Checkbox und das Datenfeld Ordnervergleich alle n Minuten können Replikationen oder Synchronisationen in beliebigen Zeitintervallen automatisch ausgeführt werden. In der neuen Version des FTP-Replikators kann die zeitgesteuerte Replikation bzw. Synchronisation darüber hinaus nicht nur mittels Angabe eines Minutenintervalls ausgeführt werden, sondern auch durch eine Zeitangabe, bestehend aus Stunde und Minute, die im Feld t äglich um einzutragen ist.

topicVergleichenVorbereitungen.html


FTP-Replikator - Vergleichen

Vergleichen

Abbildung so oder ähnlich

Über die Schaltfläche Vergleichen oder mittels des Menüs Replikation->Vergleichen... werden die Ordnerlisten miteinander verglichen. Es öffnet sich die oben abgebildete Maske, die während des gesamten Vergleichsvorgangs, der bei komplexeren Ordnerbäumen durchaus eine längere Zeit in Anspruch nehmen kann, über den jeweiligen Vergleichszustand informiert. Die Schaltfläche Vergleichen heisst während des Vergleichsvorgangs Abbrechen und dient dazu, diesen vorzeitig zu beenden.

Über die Schaltfläche Vorschau... kann die Maske mit der Liste der Replikationsobjekte bereits vor Beendigung des Vergleichsvorgangs sichtbar gemacht werden. Dies hilft beispielsweise bei Vergleichsvorgängen, die aufgrund der Vielzahl zu vergleichender Objekte eine längere Zeit in Anspruch nehmen, die Ergebnisse bereits während des Vergleichs beurteilen zu können.

Bitte beachten Sie: eine Replikation oder Synchronisation findet zu diesem Zeitpunkt noch nicht statt. Die Daten aller am Vergleich beteiligten Dateisysteme bleiben unangetastet.

topicVergleichen.html


FTP-Replikator - Programminterne Vergleichstabellen

FTP-Vergleich mit den programminternen Vergleichstabellen

Wird im FTP-Modus nur in der Richtung Links nach Rechts repliziert, so kann ein Vergleich mit dem entfernten FTP-Server stattfinden, ohne dass hierzu eine Verbindung mit dem FTP-Server aufgebaut sein muss. Der FTP-Replikator verwaltet zu dem Zweck programminterne Vergleichstabellen, die den Zustand des FTP-Servers in dem Augenblick wiederspiegeln, in dem die letzte mit ihm durchgeführte Replikation oder Synchronisation erfolgte (Snapshot-Verfahren). Mit diesem internen Zustand wird verglichen, statt mit dem realen Dateninhalt des FTP-Servers.

Zu diesem Zweck legt der FTP-Replikator in den zu replizierenden lokalen Ordnern versteckte Dateien mit den Namen _FTPEntries.dir (ehemals FTP-Replikator.dir) ab, bzw. eine einzelne Datei FTP-Replikator.dir bei aktivierter zentraler Vergleichstabelle. Bitte beachten Sie: ist ein Schreibzugriff auf die zu vergleichende Ordnerstruktur nicht möglich, so kann in der Maske Erweiterte Einstellungen die Checkbox Interne Ordner-Strukturverwaltung zentral vornehmen aktiviert werden. Dann werden alle Ordnerinformationen an einer zentralen Stelle verwaltet, nämlich im Programmordner der Anwendung.

Wurde in den erweiterten Einstellungen (Schaltfläche Erweitert... in der Hauptmaske) die Option Inverse Operationen möglich aktiviert, so muss während des Vergleichsvorgangs selbstverständlich doch wieder eine Online-Verbindung zum FTP-Server aufgebaut werden, um diejenigen Dateien erkennen zu können, die lokal (links) nicht mehr vorhanden sind, und deshalb auch auf dem FTP-Server (rechts) entfernt werden müssen.

topicVergleichenVergleichstabellen.html


FTP-Replikator - Verzeichnisse ausschließen

Bestimmte Ordner von der Replikation ausschließen

Manchmal ist es notwendig, wenige Unterordner eines sehr großen Ordnerbaums von der Replikation oder Synchronisation auszuschließen. Die Ordnerlisten müssten zu diesem Zweck sehr viele Ordner auflisten, nämlich alle zu vergleichenden Unterordner des Baums, ausser den wenigen nicht zu bearbeitenden. Das würde einen großen Verwaltungs- und Pflegeaufwand bedeuten.

Um diesen Aufwand zu minimieren, können mittels der Schaltfläche mit der Tarnkappe (von einzelnen Anwendern auch liebevoll die "Fledermausfunktion" genannt...) einzelne Unterordner eines Ordnerbaums explizit von der Bearbeitung ausgeschlossen werden. Die folgende Abbildung verdeutlicht beispielhaft Problem und Lösung:

Soll ein kompletter Ordnerbaum X, wie der links abgebildete, repliziert oder synchronisiert werden, so muss allein dieser in den Ordnerlisten angegeben werden.

Soll aber der Unterordner C von der Bearbeitung ausgeschlossen werden, dann müsste in den Ordnerlisten stattdessen der Ordner X und alle restlichen Unterordner A, B, D, E und F (ohne C) angegeben werden. Dies stellt einen hohen Verwaltungsaufwand des Anwenders dar. Als Lösung kann im FTP-Replikator jedoch weiterhin der Ordnerbaum X angegeben werden. Sein Unterordner C wird als weiterer Eintrag in die Ordnerliste geschrieben, selbst jedoch über die Schaltfläche mit der Tarnkappe als ignoriert markiert.

Wahlweise kann C allein oder auch inkl. all seiner Unterordner ausgeschlossen werden. In zweiten Fall ist die Spalte Unter des ignorierten Ordners zu aktivieren. Ansonsten wird nur C allein ausgeschlossen, nicht aber seine Unterordner.

Ein Beispiel

Angenommen, Sie besitzen auf einem entfernten FTP-Server im Ordner /public/ (und diversen Unterordnern) eine Internetpräsenz, die lokal in C:\Inetpub\wwwroot\ gepflegt wird, aber entfernt immer aktuell gehalten werden soll. Geben Sie dazu die Liste der Replikationsorder folgendermaßen an:

Linker Ordner (oder auszuschließender) | Rechter Ordner (oder entfernter) | Lösch | Unter
C:\Inetpub\wwwroot\ | /public/ |  | v

Sie stellen nach einiger Zeit fest, dass die Übertragung der vielen Bilder (nach /public/bilder/), aus denen Ihre Internetpräsenz mittlerweile besteht, immer sehr lange dauert, und das sich nur selten überhaupt ein Bild ändert. Sie beschließen daher, dieses Verzeichnis künftig von der Replikation auszuschließen. Die Liste der Replikationsordner muss hierzu folgendermaßen erweitert werden:

 | Linker Ordner (oder auszuschließender) | Rechter Ordner (oder entfernter) | Lösch | Unter
 | C:\Inetpub\wwwroot\ | /public/ |  | v
X | C:\Inetpub\wwwroot\bilder\ |  |  | v

Bitte beachten Sie, dass die zweite Zeile der Liste mit der Tarnkappenfunktion ausgeschlossen wurde. Das Häkchen in der Spalte Unter bewirkt hier, dass nicht nur der Ordner C:\Inetpub\wwwroot\bilder\ selbst von der Replikation ausgeschlossen wird, sondern auch alle seine Unterordner.

topicVergleichenVerzeichnisausschluß.html


FTP-Replikator - Zeitgesteuerte Profilausführung

Zeitgesteuerte Profilausführung

Die Liste zeigt in der Spalte Profil alle definierten Profile. Für jedes einzelne Profil kann mittels der Listenspalte Timer aktiviert entschieden werden, ob die betreffenden Ordnerbäume permanent überwacht und bei Bedarf repliziert bzw. synchronisiert werden sollen oder nicht. Die Einstellungen können über die Schaltfäche mit dem Diskettensymbol gespeichert werden. Ein Klick auf die Schaltfläche mit dem grünen Haken startet dann den Permanentvergleich aller Profile.

Das Feld Status gibt im laufenden Betrieb bei Bedarf Statsmeldungen aus.

topicVergleichenZeitgesteuert.html


FTP-Replikator - Zusätzliche Menüs

Zusätzliche Menüs

Über das Menü Hilfe->Online-Hilfe ist diese Hilfeseite aufrufbar.

Über Hilfe->Protokolldatei->einsehen... kann der Inhalt einer Datei eingesehen werden, in der die Anwendung sämtliche aussergewöhnlichen Ereignisse protokolliert, die während des Vergleichs oder der Replikation bzw. Synchronisation von Ordnern auftreten. Über das Menü Hilfe->Protokolldatei->löschen kann die Protokolldatei gelöscht werden.

Und wer dem Programm so gar nicht traut...

Über das Menü Replikation->Test-Modus kann der Test eines Replikations- bzw. Synchronisationsvorgangs durchgeführt werden. Im Fenster Replikationsobjekte sind dann zwei zusätzliche Listenspalten namens Quelle (Test) und Ziel (Test) sichtbar, die den exakten Pfad des Quell- und Zielobjekts enthalten. Der Replikationsvorgang wird in diesem Modus nicht tatsächlich ausgeführt, sondern es wird nur in einer Messagebox jeweils diejenige Operation ausgegeben, die ausgeführt werden würde.

topicVergleichenZusätzlicheMenüs.html


FTP-Replikator - Vorbereitungen zur Replikation

Replikationsobjekte

Abbildung "Replikationsobjekte"

Dieses Fenster listet alle Dateien und Ordner auf, die zur Replikation bzw. Synchronisation anstehen.

Die Spalte Fkt. zeigt, welche Operation ausgeführt werden wird: ein rotes Kreuz signalisiert, dass die betreffende Datei oder der Ordner gelöscht werden wird (diese Operation ist nur dann möglich, wenn in den erweiterten Einstellungen die Checkbox Inverse Operationen möglich aktiviert ist). Ein nach unten geknickter Pfeil zeigt an, dass die Datei oder der Ordner erstellt werden wird. Ein Doppelpfeil signalisiert die Aktualisierung einer Datei.

Die nächste Spalte symbolisiert die Richtung des Vorgangs. Das Zielobjekt, das erstellt oder aktualisiert werden wird, steht hierbei immer in Pfeilrichtung. Dabei orientiert sich die Darstellung am linken und rechten Fenster in der Hauptmaske des FTP-Replikators.

Die Spalte Datei oder Ordner enthält den Namen der betreffenden Datei oder des Ordners. Die Spalte Vorgang erläutert zusätzlich die konkrete Tätigkeit. Größe enthält die Dateigröße und ist in Ordnerzeilen leer bzw. enthält dort den Eintrag Ordner.

Im unteren Bereich befindet sich eine Übersicht über die vorzunehmenden Vorgänge, bestehend aus der Anzahl der Objekte zur Replikation insgesamt, der Anzahl der Objekte von links nach rechts und der Objekte von rechts nach links. Im rechten Teil befindet sich die Anzahl der Ordner zu erstellen/löschen, sowie die Anzahl der Dateien zu erstellen/löschen und Dateien zu aktualisieren.

Ergänzende Informationen

Ergänzende Informationen über die zu replizierenden Objekte werden angezeigt, wenn eine Zeile markiert und danach die Return-Taste gedrückt wird. Diese Maske ist ausschließlich zur Information bestimmt. Sie löst nach Druck auf die Schaltfläche Schließen selbstverständlich noch keinen Replikationsvorgang aus.

Replikationsobjekte beeinflussen

Mittels Doppelklick auf eine Zeile der Liste kann der gewählteVorgang aus der Replikation bzw. Synchronisation aus- oder wieder eingeschlossen werden. Ausgeschlossene Zeilen werden mit einem Kreuz am linken Listenrand gekennzeichnet. Alternativ ist diese Funktion auch über die Entfernen-Taste auszuführen.

In einem Kontextmenü, welches nach Klicken mit der rechten Maustaste in einer Zeile der Liste erscheint, kann mittels des Eintrags Replikationsvorgang ausschließen ebenfalls ein Vorgang aus der Liste aus- oder eingeschlossen werden. Ferner kann über den Menüpunkt Quelldatei entfernen, nicht replizieren eine Datei auf der Quellseite gelöscht werden, statt sie in Richtung Ziel zu kopieren.

In einer der nächsten Versionen des FTP-Replikators wird diese Funktionalität nicht mehr enthalten sein. Stattdessen wird eine Ersatzfunktion integriert.

topicReplikationVorbereitungen.html


FTP-Replikator - Replikation

Replizieren

Abbildung "Fortschritt"

Starten des Replikations- oder Synchronisationsvorgangs

Nach dem Klicken auf die Schaltfläche Replizieren in der Programm-Maske Replikationsobjekte wird bei Bedarf eine DFÜ-Verbindung zum FTP-Server hergestellt und der eigentliche Replikations- oder Synchronisationsvorgang gestartet. Ein Prozessfenster beschreibt dabei den jeweiligen Fortschritt innerhalb des kompletten Vorgangs (siehe Abbildung). Über die Schaltfläche Abbrechen kann der Vorgang vorzeitig beendet werden.

Aktualisierung der Dateibäume

Ein besonderes Leistungsmerkmal des FTP-Replikators ist es, die Notwendigkeit einer Replikation mit einem entfernten FTP-Server überprüfen zu können, ohne tatsächlich eine Internetverbindung zu dem FTP-Server herstellen zu müssen. Dies wird anhand programminterner Vergleichstabellen bewerkstelligt, die der FTP-Replikator automatisch aktualisiert. Vor der allerersten Replikation sind diese Vergleichstabellen jedoch noch leer, da zuvor noch nie eine Replikation mit dem Zielserver stattgefunden hat.

Die Schaltfäche Aktualisieren aktualisiert daher nur die programminternen Vergleichstabellen der lokalen FTP-Replikation von Links nach Rechts, ohne einen tatsächlichen Kopiervorgang auszulösen. Beim nächsten Vergleich werden lokaler und entfernter Datenbestand zunächst als synchron interpretiert.

Lesen Sie hierzu auch die konkrete Erläuterung dieses komplexen Vorgangs.

topicReplikation.html


FTP-Replikator - Optionen

Optionen

Über das Menü Extras->Optionen... können Sie programm-umfassenden Einstellungen vornehmen.

Im Gegensatz zu der Maske Erweiterten Einstellungen, deren Einstellungen sich nur auf das zur Zeit ausgewählte Tätigkeitsprofil beziehen, gelten die Einstellungen dieser Optionsmaske immer, also für alle Tätigkeitsprofile.

Generell

Über die Auswahlbox Debug-Level kann die augenblickliche Ebene der auszugebenden Debug-Meldungen (Zustandsmeldungen des Programms) gewählt werden. Es wird dann eine Datei namens Debug.log im Installationsverzeichnis der Anwendung angelegt, in der Programmmeldungen stehen. Folgende Ebenen stehen zur Verfügung:

  • 00 Keine Debug-Meldungen
  • 01 Nur Fehlermeldungen des Programms werden protokolliert
  • 09 Auch Zustandsmeldungen werden protokolliert
  • 10 Alle Debugmeldungen werden protokolliert (die Protokolldatei kann in diesem Fall sehr groß werden!)
Um das vollkommen unkontrollierte Wachstum der Protokolldatei zu verhindern, wird das Datum (Tag und Monat) in den Dateinamen eingebaut DebugTTMM.log, sobald die erste Debugmeldung eines neuen Tages geschrieben wird. Die neue Meldung wird sodann in eine neue Debug.log geschrieben. Die bisherige Datei bleibt künftig unangetastet.

topicOptionen.html


FTP-Replikator - Erweiterte Einstellungen

Erweiterte Einstellungen

Abbildung "Erweiterte Einstellungen" (Abbildung so oder ähnlich)

Vorbedingungen der Replikation

Der tatsächliche Start des Replikations- oder Synchronisationsvorgangs kann von der Vorbedingung abhängig gemacht werden, ob ein Ordner mit dem im Feld Ordner angegebenen Namen leer bzw. gefüllt ist. Ist diese Vorbedingung nicht erfüllt, wird der Vorgang nicht gestartet.

Automatische Ausführung einer Anwendung

Nach jedem ausgeführten Vergleich, der tatsächlich zu einer Replikation oder Synchronisation führte, kann automatisch eine beliebige Drittanwendung gestartet werden. Der Name der Anwendung ist mittels der Schaltfläche hinter dem Feld Name auszuwählen. Ist das Feld leer, wird keine Anwendung ausgeführt. Zum Aufruf der Anwendung notwendige Argumente können in das entsprechende Feld Argumente eingetragen werden.

Sonstige Einstellungen

Einzelheiten zur Einstellung mittels der Checkbox Interne Ordner-Strukturverwaltung zentral vornehmen entnehmen Sie bitte dem Kapitel FTP-Vergleich mit den programminternen Vergleichstabellen.

Ist die Checkbox Alle replizierten oder synchronisierten Objekte protokollieren aktiviert, dann wird jedes replizierte oder synchronisierte Objekt (Datei oder Ordner) in der Logdatei protokolliert, und nicht nur das Auftreten eines Fehlers. Die Logdatei kann über das Menü Hilfe->Protokolldatei->einsehen... betrachtet werden.

Soll die Anwendung unbeaufsichtigt auf einem PC laufen, an dem sich verschiedene Benutzer anmelden könnten, so ist es nicht zweckmäßig, die Einstellungen des FTP-Replikators im Benutzeranteil der Registry zu speichern. Stattdessen sollten die Einstellungen im Maschinenanteil gespeichert werden. Dazu muss die Checkbox Registry-Einstellungen im Maschinenanteil speichern aktiviert werden.

Wenn Sie den vorangegangenen Absatz nicht verstanden haben, und auch nicht wissen, was eine Registry eigentlich ist, so ist das nicht weiter schlimm. Im allgemeinen muss diese Einstellung vom Benutzer ohnehin nicht geändert werden.

Zeitzonen und Windows XP

Manchmal unterscheiden sich die zu vergleichenden Dateisysteme nur aufgrund unterschiedlicher Zeitzonen, in denen sich die betreffenden Computersysteme befinden. Dies führt dazu, dass Dateien beim Vergleich aufgrund ihres unterschiedlichen Dateimodifikationsdatums als nicht identisch erkannt werden, obwohl sie es in Wirklichkeit doch sind. Ist die Checkbox Zeitzonenverschiebung um +/- nnn Stunden aktiviert und eine Verschiebung um nnn Stunden (größer null) eingestellt, so wird die Differenz der Dateimodifikationsdaten automatisch kompensiert, die sich aus der Zeitzonenverschiebung ergibt. Die Kompensation erfolgt automatisch sowohl in negativer als auch in positiver Richtung.

Während alle Windows-Versionen vor Windows XP das Modifikationsdatum von Dateien nur mit sekundengenauer Auflösung vermerken (der Millisekundenanteil ist bei diesen Versionen immer null), bewerkstelligt Windows XP dies mit einer Auflösung im Millisekundenbereich. Das führt beim Vergleich zwischen XP- und Nicht-XP-Dateisystemen dazu, dass Dateien aufgrund der Millisekunden-Differenz ihres Dateimodifikationsdatums nicht als identisch erkannt werden, obwohl sie es in Wirklichkeit doch sind. Diese Differenz kann durch das Aktivieren der Checkbox Windows XP-Dateisystemkompensation innerhalb desjenigen Sekundenbereiches ausgeglichen werden, der im Datenfeld hinter der Checkbox angegeben wird..

Achtung: werden bei aktivierter Checkbox jedoch zwei XP-Dateisysteme miteinander verglichen, in denen sich der Modifikationszeitpunkt zweier Dateien tatsächlich nur um wenige Millisekunden voneinander unterscheidet, was in der Praxis hoffentlich nie passieren wird, so werden diese Dateien niemals als unterschiedlich erkannt werden!

Inverse Operation

Die Checkbox Inverse Operationen möglich aktiviert die Löschfunktion bei Replikationsvorgängen von links nach rechts bzw. von rechts nach links. Ist diese Checkbox aktiviert, so werden Dateien oder Ordner, die im Zieldateisystem existieren, jedoch nicht im Quelldateisystem, während des Replikationsvorgangs gelöscht.

Bei Synchronisationsvorgängen zwischen Dateisystemen werden Dateien und Ordner niemals gelöscht, da algorithmisch für die Anwendung keine Möglichkeit besteht, festzustellen, ob ein Löschen notwendig wäre. Vielmehr wird der betreffende Ordner bzw. die Datei auf der "anderen Dateisystemseite" erstellt.

topicVergleichenErweiterteEinstellungen.html


FTP-Replikator - Erweiterte FTP-Einstellungen

Erweiterte FTP-Einstellungen

Abbildung "Erweiterte FTP-Einstellungen"

Gruppe Internet-Verbindung

In der Gruppe Internet-Verbindung kann zwischen Internet über lokales Netzwerk (LAN) und einer Einwahl-Verbindung über Modem gewählt werden. Zur Verbindungsaufnahme mit einem FTP-Server wird bei aktivierter Modem-Einstellung ein Verbindungsaufbau mittels des im (RAS-) Profil ausgewählten DFÜ-Eintrags des DFÜ-Netzwerks versucht. Bei Verbindung über das lokale Netzwerk (LAN) geht der FTP-Replikator dagegen von einer bereits bestehenden Netzwerkverbindung aus, und versucht nicht von selbst, eine solche Verbindung herzustellen.

Konfigurieren Sie also die Internetverbindung über ein lokales Netzwerk, sofern Sie ohnehin immer mit dem Internet verbunden sind (beispielsweise mit einer Kabelmodem-/DSL-Flatrate usw.), oder aber die Modem-Verbindung, wenn Sie zunächst eine Internetverbindung herstellen müssen, bevor Sie ins Internet gelangen können.

Über die Einstellung Passive Verbindung aufbauen kann die FTP-Verbindung im sogenannten Passive Mode aufgebaut werden. Hierbei teilt der FTP-Server dem FTP-Client die IP-Adresse und den Port des FTP Data Port mit, an dem der Client sich verbinden kann. Im Active Mode ist Port 20 immer der FTP Data Port.

Gruppe Proxyserver

In der Gruppe Proxyserver kann ein ebensolcher Proxy spezifiziert werden. Dazu ist die Angabe seiner IP-Adresse und der Anschlussnummer (Port) notwendig.

Das Aktivieren der Checkbox Proxy-Caches durch Umbenennen von Dateien überlisten zwingt den FTP-Replikator vor der Übertragung einer entfernten FTP-Datei, diese auf dem FTP-Server temporär umzubenennen. Hierdurch wird ausgeschlossen, dass dateinamen-orientierte Proxyserver eine nicht-aktuelle Kopie der Datei statt der ursprünglichen Datei zurückliefern. Nach Abschluss der Übertragung wird die ursprüngliche Datei auf dem Server wieder zurückbenannt.

Sonstige Einstellungen

Ferner kann über die Schaltfläche Timeout für FTP-Verbindung die Wartezeit bis zur erfolglosen Verbindungsversuch mit einem FTP-Server eingestellt werden, mit Wiederholung bei FTP-Fehlern die Anzahl der Wiederholungsversuche beim Übertragen von Dateien und Erstellen von Ordnern und mit Dateien zur ASCII-Übertragung die Dateinamen-Endungen, die mittels des FTP-Übertragungsattributes ASCII (Type A) bzw. IMAGE (Type I) übertragen werden sollen.

topicErweiterteFTPEinstellungen.html


FTP-Replikator - Schnelleinstieg

Schnelleinstieg

Damit Sie möglichst schnell und sinnvoll mit dem FTP-Replikator arbeiten können, finden Sie auf dieser Seite einen Schnelleinstieg, der Sie möglichst kurz und knapp durch alle wichtigen Schritte der Bedienung führt.

1.

Wählen Sie den Modus der Replikation oder Synchronisation

Möchten Sie ein lokales Dateisystem (oder eines im LAN) mit einem FTP-Server vergleichen, so aktivieren Sie in der Hauptmaske der Anwendung die Schaltfläche FTP, die einer Tonne ähnlich sieht. Möchten Sie jedoch ausschließlich lokale Dateisysteme (oder welche im LAN) miteinander vergleichen, so aktivieren Sie die Schaltfläche nicht.

Fahren Sie mit dem nächsten Punkt fort, sofern sie mit einem FTP-Server vergleichen, ansonsten mit Punkt 3.
2.

FTP-Server wählen und konfigurieren

Im FTP-Modus müssen Sie den Servernamen des FTP-Servers im Feld FTP-Server, einen gültigen Benutzernamen im Feld Benutzer, sowie ein Kennwort im Feld K ennwort eingeben. Hierzu dient das Fenster auf der rechten Seite der Überschrift Ordnerbaum.

Klicken Sie nun auf die Schaltfläche Erweitert... im rechten Listenfenster. Geben Sie in der Gruppe Internet-Verbindung an, ob sie permanent mit dem Internet verbunden sind Internet über lokales Netzwerk (LAN) oder über ein Modem Einwahl-Verbindung über Modem. Für den zweiten Fall geben Sie im Feld Profil noch den RAS-Eintrag des DFÜ-Netzwerks an, über den die Verbindung ins Internet aufgebaut werden soll. Lesen Sie bei Bedarf zum Thema DFÜ-Netzwerk in der Bedienungsanleitung Ihres Betriebssystems nach.
3.

Zu vergleichende Ordner auswählen

Wählen Sie im linken Fenster der Überschrift Ordnerbaum einen Ordner aus, welchen Sie inklusive all seiner Unterordner mit einem entsprechenden Ordnerbaum auf dem FTP-Server bzw. einem anderen lokalen Ordner (oder einen im LAN) vergleichen möchten. Im zweiten Fall wählen Sie im rechten Fenster der Überschrift Ordnerbaum den korrespondierenden Ordner aus.

Klicken Sie nun auf die Schaltfläche mit dem grünen Haken im Ordner, um den einen bzw. die beiden ausgewählten Ordner in die Liste der Replikationsordner zu übernehmen.

Im FTP-Modus müssen Sie nun in der Liste der Replikationsordner den soeben in die Liste gestellten entfernten Ordner noch konkret spezifizieren. Der FTP-Replikator gibt zwar einen Ordnernamen vor, dieser stellt aber nur eine Annahme dar, die nicht stimmen muss.

Wiederholen Sie diesen Punkt, bis sämtliche gewünschten Ordner in der Liste der Replikationsordner enthalten sind.
4. Richtung der Replikation oder Synchronisation wählen

Wählen Sie nun die Richtung der Replikation oder Synchronisation mittels der Schaltflächen Pfeil nach rechts, Pfeil nach links oder Pfeil nach links und rechts.

Die Richtung der Replikation orientiert sich am linken und rechten Ordner der Liste der Replikationsordner. Die Pfeilrichtung zeigt hierbei immer an, in welche Richtung repliziert wird, nämlich von der Quelle zum Ziel. Die Pfeilrichtung von links nach rechts bedeutet beispielsweise, dass die Ordner, die in der Liste der Replikationsordner links stehen, mit denen auf der rechten Seite verglichen werden. Wird ein neuer Ordner oder eine neue Datei auf der linken Seite entdeckt, oder ist eine Datei auf der linken Seite aktueller als das korrespondierende Objekt auf der rechten Seite, so wird der Ordner oder die Datei nach rechts kopiert. Wird hingegen auf der rechten Seite ein Ordner oder eine Datei gefunden, die auf der linken Seite nicht existiert, so wird der Ordner oder die Datei auf der rechten Seite gelöscht.

Wählen Sie eine Synchronisation (Pfeil nach links und rechts) und keine Replikation, so werden die Ordner in beiden Richtungen verglichen und neue Ordner oder Dateien jeweils in die andere Richtung kopiert, unabhängig davon, ob sie sich links oder rechts in der Liste der Replikationsordner befinden.
5. Profil speichern

Wählen Sie im oberen Teil des Hauptfensters im Feld P rofil einen beschreibenden Namen für die Replikation oder Synchronisation und speichern Sie dann das Profil mittels der Schaltfläche mit dem Diskettensymbol.
6. Vergleich durchführen

Klicken Sie auf die Schaltfläche Vergleichen und warten Sie das Ende des Vorgangs ab.
7. Replikation oder Synchronisation durchführen

Prüfen Sie die in der Liste der Replikationsobjekte aufgeführten Ordner und Dateien, sowie die angegebene Operation. Klicken Sie dann auf die Schaltfläche Replizieren, um den Replikations- oder Synchronisationsvorgang zu starten.

topicSchnelleinstieg.html


FTP-Replikator - Bekannte Fehler

Bekannte Fehler

1.

Zur Internet-Einwahl mittels Wahlzugang (Modem, ISDN, Kabelmodem etc.) setzt der FTP-Replikator die Installation des Windows DFÜ-Netzwerks voraus. Bitte konsultieren Sie Ihr Windows-Handbuch, um sicherzustellen, dass das DFÜ-Netzwerk auf Ihrem Rechner installiert ist. Unter Microsoft® Windows™ 95 könnte eine der unten abgebildeten Fehlermeldungen auftreten, wenn Sie ohne installiertes DFÜ-Netzwerk versuchen, eine Einwahlverbindung herzustellen.

topicFehler.html


FTP-Replikator - Nutzen der Replikation
Stand: 08. Oktober 2002

Der FTP-Replikator für die Betriebssysteme Microsoft® Windows™ 95, 98 und 98 Second Edition (SE), sowie Windows NT, 2000 und XP ist eine Lösung zur unternehmensweiten Replikation und Synchronisation aller Daten auf lokalen Rechnern, Dateiservern sowie im Intra- und Internet. Der FTP-Replikator schützt durch seine einfache Bedienung und seine vollautomatische, zeitgesteuerte Funktion sehr effektiv vor kritischem Datenverlust. Das Programm nutzt die sogenannte synchrone Replikation, um den allerhöchsten Grad der Datenintegrität zu gewährleisten: bei dieser Methode bleiben alle beteiligten Dateisysteme während des Sicherungsvorgangs on-line, und stehen dem Benutzer somit weiterhin zur Verfügung. Ferner ist diese Methode transparent für jede existierende Anwendung, für lokale wie für entfernte.

FTP-Replikation

Mit der zukünftig immer weiter ansteigenden Bedeutung des Webs wird die Verfügbarkeit entfernter Web-Dienste zu einer kritischen Komponente im Unternehmensprozess. Das Bedürfnis nach synchronisierten Webinhalten über mehrere Webserver hinweg verlangt nach einer Lösung, die in der Lage ist, effektiv Daten auf alle Server zu verteilen. Der FTP-Replikator erlaubt die Verteilung dynamischer Web-Inhalte über ein lokales (LAN) oder weit entferntes Netzwerk (WAN), und stellt dabei jederzeit die Authentizität des übertragenen Dateninhalts sicher. Die synchrone Replikation garantiert ausserdem, dass alle Server fast zu jedem Zeitpunkt Zugriff auf identische Kopien aller Daten besitzen. Dies bedeutet, dass jede Modifikation des Dateninhalts auf einem Server zu einer zügigen Änderung der Daten auf allen anderen beteiligten Servern führt.

Gesteigerte Datenverfügbarkeit

Der FTP-Replikator ermöglicht zudem die Replikation kompletter Dateisysteme oder einzelner Ausschnitte, welche sich an unterschiedlichsten Lokationen befinden können. Dies ermöglicht entfernt arbeitenden Benutzern den lokalen Zugriff auf synchrone Unternehmensdaten, was besonders in solchen Unternehmen von großer Bedeutung ist, in denen eine Vielzahl von Benutzern gleichzeitig Zugriff auf hochaktuelle Dokumente haben muss.

Im Falle eines Verbindungsverlusts im Netzwerk, der eine permanente Replikation verhindert, erlaubt der FTP-Replikator nach der Schadensbehebung die schnelle Re-Synchronisation aller betroffenen Dateisysteme.

Zusammenfassung

Ob durch die Notwendigung der Erweiterung von Web- und Dateiservern motiviert, durch die Notwendigkeit schneller und zuverlässiger Datenreplikation im Fall eines Hardwaredefektes oder der Auslagerung von Servern, bietet der FTP-Replikator die Leistungsfähigkeit, die zur Bewältigung dieser Aufgaben benötigt wird. Ob als Einzellösung oder im gesamten Unternehmen verwendet, stellt der FTP-Replikator die ideale Lösung für die heutigen Aufgaben der Datenreplikation dar.

Online-Hilfe
Abbildungen mit freundlicher Genehmigung.
Copyright VERITAS Software Corporation

Copyright © 2000-2002 Geist Informatik. Alle Rechte vorbehalten.
www.geist-informatik.de

Nutzen.html